Common Diagram & Basic Configuration

Common Diagram

 

Basic Configuration

!!! R1
hostname R1
no ip domain lookup
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
 ipv6 address fd00:10::1/128
!
interface Ethernet1/0
 no ip address
 no shutdown
!
interface Ethernet1/0.15
 encapsulation dot1Q 15
 ip address 10.1.5.1 255.255.255.0
 ipv6 address fd00:10:1:5::1/64
!
interface Ethernet1/0.16
 encapsulation dot1Q 16
 ip address 10.1.6.1 255.255.255.0
 ipv6 address fd00:10:1:6::1/64
!
interface Ethernet1/0.17
 encapsulation dot1Q 17
 ip address 10.1.7.1 255.255.255.0
 ipv6 address fd00:10:1:7::1/64
!
interface Ethernet1/0.19
 encapsulation dot1Q 19
 ip address 10.1.9.1 255.255.255.0
 ipv6 address fd00:10:1:9::1/64
!
!!! R2
hostname R2
no ip domain lookup
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 ip address 10.0.0.2 255.255.255.255
 ipv6 address fd00:10::2/128
!
interface Ethernet1/0
 no ip address
 no shutdown
!
interface Ethernet1/0.29
 encapsulation dot1Q 29
 ip address 10.2.9.2 255.255.255.0
 ipv6 address fd00:10:2:9::2/64
!
interface Ethernet1/0.210
 encapsulation dot1Q 210
 ip address 10.2.10.2 255.255.255.0
 ipv6 address fd00:10:2:10::2/64
!
interface Ethernet1/0.268
 encapsulation dot1Q 268
 ip address 10.26.8.2 255.255.255.0
 ipv6 address fd00:10:26:8::2/64
!
!!! R3
hostname R3
no ip domain lookup
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 ip address 10.0.0.3 255.255.255.255
 ipv6 address fd00:10::3/128
!
interface Ethernet1/0
 no ip address
 no shutdown
!
interface Ethernet1/0.37
 encapsulation dot1Q 37
 ip address 10.3.7.3 255.255.255.0
 ipv6 address fd00:10:3:7::3/64
!
interface Ethernet1/0.39
 encapsulation dot1Q 39
 ip address 10.3.9.3 255.255.255.0
 ipv6 address fd00:10:3:9::3/64
!
!!! R4
hostname R4
no ip domain lookup
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 ip address 10.0.0.4 255.255.255.255
 ipv6 address fd00:10::4/128
!
interface Ethernet1/0
 no ip address
 no shutdown
!
interface Ethernet1/0.46
 encapsulation dot1Q 46
 ip address 10.4.6.4 255.255.255.0
 ipv6 address fd00:10:4:6::4/64
!
interface Ethernet1/0.48
 encapsulation dot1Q 48
 ip address 10.4.8.4 255.255.255.0
 ipv6 address fd00:10:4:8::4/64
!
!!! R5
hostname R5
no ip domain lookup
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 ip address 10.0.0.5 255.255.255.255
 ipv6 address fd00:10::5/128
!
interface Ethernet1/0
 no ip address
 no shutdown
!
interface Ethernet1/0.15
 encapsulation dot1Q 15
 ip address 10.1.5.5 255.255.255.0
 ipv6 address fd00:10:1:5::5/64
!
!!! R6
hostname R6
no ip domain lookup
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 ip address 10.0.0.6 255.255.255.255
 ipv6 address fd00:10::6/128
!
interface Ethernet1/0
 no ip address
 no shutdown
!
interface Ethernet1/0.16
 encapsulation dot1Q 16
 ip address 10.1.6.6 255.255.255.0
 ipv6 address fd00:10:1:6::6/64
!
interface Ethernet1/0.46
 encapsulation dot1Q 46
 ip address 10.4.6.6 255.255.255.0
 ipv6 address fd00:10:4:6::6/64
!
interface Ethernet1/0.68
 encapsulation dot1Q 68
 ip address 10.6.8.6 255.255.255.0
 ipv6 address fd00:10:6:8::6/64
!
interface Ethernet1/0.268
 encapsulation dot1Q 268
 ip address 10.26.8.6 255.255.255.0
 ipv6 address fd00:10:26:8::6/64
!
!!! R7
hostname R7
no ip domain lookup
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 ip address 10.0.0.7 255.255.255.255
 ipv6 address fd00:10::7/128
!
interface Ethernet1/0
 no ip address
 no shutdown
!
interface Ethernet1/0.17
 encapsulation dot1Q 17
 ip address 10.1.7.7 255.255.255.0
 ipv6 address fd00:10:1:7::7/64
!
interface Ethernet1/0.37
 encapsulation dot1Q 37
 ip address 10.3.7.7 255.255.255.0
 ipv6 address fd00:10:3:7::7/64
!
interface Ethernet1/0.79
 encapsulation dot1Q 79
 ip address 10.7.9.7 255.255.255.0
 ipv6 address fd00:10:7:9::7/64
!
!!! R8
hostname R8
no ip domain lookup
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 ip address 10.0.0.8 255.255.255.255
 ipv6 address fd00:10::8/128
!
interface Ethernet1/0
 no ip address
 no shutdown
!
interface Ethernet1/0.48
 encapsulation dot1Q 48
 ip address 10.4.8.8 255.255.255.0
 ipv6 address fd00:10:4:8::8/64
!
interface Ethernet1/0.68
 encapsulation dot1Q 68
 ip address 10.6.8.8 255.255.255.0
 ipv6 address fd00:10:6:8::8/64
!
interface Ethernet1/0.268
 encapsulation dot1Q 268
 ip address 10.26.8.8 255.255.255.0
 ipv6 address fd00:10:26:8::8/64
!
!!! R9
hostname R9
no ip domain lookup
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 ip address 10.0.0.9 255.255.255.255
 ipv6 address fd00:10::9/128
!
interface Ethernet1/0
 no ip address
 no shutdown
!
interface Ethernet1/0.19
 encapsulation dot1Q 19
 ip address 10.1.9.9 255.255.255.0
 ipv6 address fd00:10:1:9::9/64
!
interface Ethernet1/0.29
 encapsulation dot1Q 29
 ip address 10.2.9.9 255.255.255.0
 ipv6 address fd00:10:2:9::9/64
!
interface Ethernet1/0.39
 encapsulation dot1Q 39
 ip address 10.3.9.9 255.255.255.0
 ipv6 address fd00:10:3:9::9/64
!
interface Ethernet1/0.79
 encapsulation dot1Q 79
 ip address 10.7.9.9 255.255.255.0
 ipv6 address fd00:10:7:9::9/64
!
!!! R10
hostname R10
no ip domain lookup
ip cef
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 ip address 10.0.0.10 255.255.255.255
 ipv6 address fd00:10::10/128
!
interface Ethernet1/0
 no ip address
 no shutdown
!
interface Ethernet1/0.210
 encapsulation dot1Q 210
 ip address 10.2.10.10 255.255.255.0
 ipv6 address fd00:10:2:10::10/64
!