DMVPN NHRP

REFERENCE

Configuring NHRP

NHRP の設定

NOTE

NHS,NHC

(cinfig-if)# ip nhrp network-id
(cinfig-if)# ip nhrp authentication
(cinfig-if)# ip nhrp holdtime

NHS (Hub)

(cinfig-if)# ip nhrp map multicast dynamic

NHC (Spoke)

(cinfig-if)# ip nhrp nhs <HHS IP Address>
(cinfig-if)# ip nhrp map <NHS IP Address> <NHS NBMA Address>
(cinfig-if)# ip nhrp map multicast <NHS NBMA Address>

  • ip nhrp registration timeout
    NHCは自身の情報をNHSに登録要求を出すが、その送信間隔を任意に指定できる
    このコマンドを使わない場合はデフォルトではip nhrp holdtimeの1/3に設定される
    ip nhrp holdtimeのデフォルトは7200秒なので2400秒になる
  • ip nhrp holdtime
    NHSがNHCのマッピング情報を有効情報として保持する時間
    デフォルトは7200秒
!!! R1
interface Tunnel0
 ip address 192.168.13.1 255.255.255.0
 no ip redirects
 ip nhrp authentication cisco
 ip nhrp map multicast dynamic
 ip nhrp network-id 1
 ip ospf 1 area 0
 tunnel source FastEthernet1/0
 tunnel mode gre multipoint
end

!!! R3
interface Tunnel0
 ip address 192.168.13.3 255.255.255.0
 no ip redirects
 ip nhrp authentication cisco
 ip nhrp map multicast 10.1.2.1
 ip nhrp map 192.168.13.1 10.1.2.1
 ip nhrp network-id 1
 ip nhrp nhs 192.168.13.1
 ip ospf 1 area 0
 tunnel source FastEthernet0/0
 tunnel mode gre multipoint
end

 

左がR1(NHS)、右がR3(NHC)

 

コメント