EIGRP ネイバーとのサブネットマスクが異なるとどうなるのか?

NOTE

  • EIGRPでネイバーとのサブネットマスクが異なるとどうなるのか?

VERIFICATION

  • ネイバーは張れている
R1#sh ip ei nei
EIGRP-IPv4 VR(CCIE) Address-Family Neighbors for AS(65000)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   10.1.9.9                Et1/0.19                 11 00:00:37 1585  5000  0  38
0   10.1.7.7                Et1/0.17                 11 01:13:16   29   174  0  38
R1#

R7#sh ip ei nei
EIGRP-IPv4 VR(CCIE) Address-Family Neighbors for AS(65000)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   10.7.9.9                Et1/0.79                 11 01:12:46   17   102  0  37
0   10.1.7.1                Et1/0.17                 13 01:13:36   99   594  0  37
R7#

R9#sh ip ei nei
EIGRP-IPv4 VR(CCIE) Address-Family Neighbors for AS(65000)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   10.1.9.1                Et1/0.19                 14 00:01:09   30   180  0  38
1   10.7.9.7                Et1/0.79                 13 01:12:57  161   966  0  39
R9#

 

  • R7のshow ip route に違和感が・・・
R1#sh ip ro | b Gate
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
C        10.0.0.1/32 is directly connected, Loopback0
C        10.1.7.0/24 is directly connected, Ethernet1/0.17
L        10.1.7.1/32 is directly connected, Ethernet1/0.17
C        10.1.9.0/24 is directly connected, Ethernet1/0.19
D        10.1.9.0/25 [90/2048000] via 10.1.7.7, 00:09:21, Ethernet1/0.17
L        10.1.9.1/32 is directly connected, Ethernet1/0.19
D        10.7.9.0/24 [90/1536000] via 10.1.9.9, 00:09:16, Ethernet1/0.19
                     [90/1536000] via 10.1.7.7, 00:09:16, Ethernet1/0.17
R1#

R7#sh ip ro | b Gate
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
C        10.0.0.7/32 is directly connected, Loopback0
C        10.1.7.0/24 is directly connected, Ethernet1/0.17
L        10.1.7.7/32 is directly connected, Ethernet1/0.17
D        10.1.9.0/24 [90/1536000] via 10.1.7.1, 00:09:49, Ethernet1/0.17
D        10.1.9.0/25 [90/1536000] via 10.7.9.9, 00:09:49, Ethernet1/0.79
C        10.7.9.0/24 is directly connected, Ethernet1/0.79
L        10.7.9.7/32 is directly connected, Ethernet1/0.79
R7#

R9#sh ip ro | b Gate
Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
C        10.0.0.9/32 is directly connected, Loopback0
D        10.1.7.0/24 [90/1536000] via 10.7.9.7, 00:10:02, Ethernet1/0.79
                     [90/1536000] via 10.1.9.1, 00:10:02, Ethernet1/0.19
D        10.1.9.0/24 [90/2048000] via 10.7.9.7, 00:10:07, Ethernet1/0.79
C        10.1.9.0/25 is directly connected, Ethernet1/0.19
L        10.1.9.9/32 is directly connected, Ethernet1/0.19
C        10.7.9.0/24 is directly connected, Ethernet1/0.79
L        10.7.9.9/32 is directly connected, Ethernet1/0.79
R9#

 

  • 遠回りするがLocal routeにより到達はできるが、同じセグメントの異なるアドレスだと周り続ける
R7#traceroute 10.1.9.1
Type escape sequence to abort.
Tracing the route to 10.1.9.1
VRF info: (vrf in name/id, vrf out name/id)
  1 10.7.9.9 16 msec 20 msec 12 msec
  2 10.1.9.1 20 msec 24 msec 32 msec
R7#

R7#traceroute 10.1.9.2
Type escape sequence to abort.
Tracing the route to 10.1.9.2
VRF info: (vrf in name/id, vrf out name/id)
  1 10.7.9.9 16 msec 32 msec 8 msec
  2 10.1.9.1 92 msec 0 msec 20 msec
  3 10.1.7.7 20 msec 20 msec 16 msec
  4 10.7.9.9 36 msec 36 msec 32 msec
  5 10.1.9.1 24 msec 36 msec 48 msec
  6 10.1.7.7 48 msec 36 msec 44 msec
  7 10.7.9.9 56 msec 44 msec 48 msec
  8 10.1.9.1 52 msec 56 msec 60 msec
  9 10.1.7.7 60 msec 56 msec 60 msec
 10 10.7.9.9 72 msec 80 msec 76 msec
 11 10.1.9.1 100 msec 68 msec 68 msec
 12 10.1.7.7 80 msec 76 msec 76 msec
 13 10.7.9.9 96 msec 96 msec 68 msec
 14 10.1.9.1 80 msec 60 msec 60 msec
 15 10.1.7.7 56 msec 84 msec 92 msec
 16 10.7.9.9 120 msec 104 msec 108 msec
 17 10.1.9.1 100 msec 116 msec 96 msec
 18 10.1.7.7 84 msec 60 msec 64 msec
 19 10.7.9.9 84 msec 128 msec 132 msec
 20 10.1.9.1 140 msec 124 msec 132 msec
 21 10.1.7.7 88 msec 88 msec 96 msec
 22 10.7.9.9 124 msec 112 msec 148 msec
 23 10.1.9.1 140 msec 116 msec 136 msec
 24 10.1.7.7 164 msec 160 msec 144 msec
 25 10.7.9.9 168 msec 168 msec 184 msec
 26 10.1.9.1 164 msec 152 msec 188 msec
 27 10.1.7.7 188 msec 180 msec 184 msec
 28 10.7.9.9 176 msec 156 msec 196 msec
 29 10.1.9.1 144 msec 196 msec 160 msec
 30 10.1.7.7 212 msec 188 msec 204 msec
R7#

 

DIAGRAM & CONFIGURATION

!!! R1
interface Ethernet1/0.15
 shutdown
!
interface Ethernet1/0.16
 shutdown
!
router eigrp CCIE
 address-family ipv4 unicast autonomous-system 65000
  network 10.1.7.1 0.0.0.0
  network 10.1.9.1 0.0.0.0
  eigrp router-id 10.0.0.1

!!! R7
interface Ethernet1/0.37
 shutdown
!
router eigrp CCIE
 address-family ipv4 unicast autonomous-system 65000
  network 10.1.7.7 0.0.0.0
  network 10.7.9.7 0.0.0.0
  eigrp router-id 10.0.0.7

!!! R9
interface Ethernet1/0.19
 ip address 10.1.9.9 255.255.255.128
!
interface Ethernet1/0.29
 shutdown
!
interface Ethernet1/0.39
 shutdown
!
router eigrp CCIE
 address-family ipv4 unicast autonomous-system 65000
  network 10.1.9.9 0.0.0.0
  network 10.7.9.9 0.0.0.0
  eigrp router-id 10.0.0.9

 

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です