Generic Routing Encapsulation (GRE)

Generic Routing Encapsulation (GRE)

NOTE

  • デオフォルトのUp/Down 判定は宛先に到達性があること
R1(config)#interface Tunnel1
R1(config-if)# ip address 10.1.1.1 255.255.255.0
R1(config-if)# tunnel source FastEthernet1/0
R1(config-if)# tunnel destination 10.3.3.3
  • keepalive を使うと、宛先に到達性があっても、keepaliveを元にUp/Downを判定できる
  • 送信間隔とリトライを指定できる
R1(config-if)#keepalive ?
  <0-32767>  Keepalive period (default 10 seconds)
R1(config-if)#keepalive 1 ?
  <1-255>  Keepalive retries

 

Tunnels & Recursive Routing Errors

NOTE

Loopback Address 10.x.x.x/24
Tunnel Address 192.168.1.x/24
[R1]—–[R2]—–[R3]

  1. 10.3.3.0 宛がトンネルIFに入る
  2. トンネルIFはパケットにGREヘッダをつける
  3. そのパケットはトンネルIFの宛先アドレス宛に送る
  4. 192.168.1.3は192.168.1.0/24なので、tunnnel0に送る
    ⇒ またトンネルに入るのでループする
int tunnel 0
 ip add 192.168.1.1 255.255.255.0
 tunnel source loopback 0
 tunnel destination 10.3.3.3
router eigrp 1
 net 10.1.1.0 0.0.0.255 ← Loopback
 net 192.168.1.0        ← Tunnnel
show ip route
 D 10.3.3.0 via 192.168.1.3  tunnel 0
 c 192.168.1.0/24 connected  tunnel 0
  • distribute-list を使ってtunnelのsourceを抑制する
  • かけるIFはtunnel
interface Tunnel13
 ip address 192.168.13.1 255.255.255.0
 tunnel source 10.0.12.1
 tunnel destination 10.0.23.3
!
router rip
 version 2
 network 10.0.0.0
 network 192.168.13.0
 distribute-list prefix STOP-RECURSIVE-ERROR out Tunnel13
 no auto-summary
!
ip prefix-list STOP-RECURSIVE-ERROR seq 10 deny 10.0.12.0/24
ip prefix-list STOP-RECURSIVE-ERROR seq 1000 permit 0.0.0.0/0 le 32

 

コメント