MPLS Label Filtering

TASK

受信/送信ラベルフィルタリングを確認する

受信ラベルフィルタリング

指定したネイバーから特定のアドレスについてのラベルだけを受信する。

DIAGRAM

 

 

CONFIG

hostname R1
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
 ip ospf 1 area 0
!
interface FastEthernet0/0
 no ip address
 shutdown
!
interface FastEthernet1/0
 ip address 192.168.123.1 255.255.255.0
 ip ospf 1 area 0
 no shutdown
!
router ospf 1
 mpls ldp autoconfig
 router-id 10.0.0.1
!
mpls ldp router-id Loopback0 force
!
end
hostname R2
!
interface Loopback0
 ip address 10.0.0.2 255.255.255.255
 ip ospf 1 area 0
!
interface FastEthernet0/0
 ip address 192.168.123.2 255.255.255.0
 ip ospf 1 area 0
 no shutdown
!
interface FastEthernet1/0
 ip address 192.168.234.2 255.255.255.0
 ip ospf 1 area 0
 no shutdown
!
router ospf 1
 mpls ldp autoconfig
 router-id 10.0.0.2
!
mpls ldp router-id Loopback0 force
!
end
hostname R3
!
interface Loopback0
 ip address 10.0.0.3 255.255.255.255
 ip ospf 1 area 0
!
interface FastEthernet0/0
 ip address 192.168.123.3 255.255.255.0
 ip ospf 1 area 0
 no shutdown
!
interface FastEthernet1/0
 ip address 192.168.234.3 255.255.255.0
 ip ospf 1 area 0
 no shutdown
!
router ospf 1
 mpls ldp autoconfig
 router-id 10.0.0.3
!
mpls ldp router-id Loopback0 force
!
end
hostname R4
!
interface Loopback0
 ip address 10.0.0.4 255.255.255.255
 ip ospf 1 area 0
!
interface Loopback4
 ip address 10.4.4.4 255.255.255.255
 ip ospf 1 area 0
!
interface FastEthernet0/0
 ip address 192.168.234.4 255.255.255.0
 ip ospf 1 area 0
 no shutdown
!
interface FastEthernet1/0
 no ip address
 shutdown
!
router ospf 1
 mpls ldp autoconfig
 router-id 10.0.0.4
!
mpls ldp router-id Loopback0 force
!
end

VERIFY

何もしていない状態ではR1はネイバであR2とR3からIGP エントリとして10.0.0.4と10.4.4.4を受信し、ラベル付与。OSPFなので受信ではないが細かいことは省略。

R1#show mpls ip binding
  10.0.0.1/32
        in label:     imp-null
        out label:    18        lsr: 10.0.0.2:0
        out label:    18        lsr: 10.0.0.3:0
  10.0.0.2/32
        in label:     19
        out label:    imp-null  lsr: 10.0.0.2:0       inuse
        out label:    17        lsr: 10.0.0.3:0
  10.0.0.3/32
        in label:     18
        out label:    17        lsr: 10.0.0.2:0
        out label:    imp-null  lsr: 10.0.0.3:0       inuse
  10.0.0.4/32
        in label:     17
        out label:    16        lsr: 10.0.0.2:0       inuse
        out label:    16        lsr: 10.0.0.3:0       inuse
  10.4.4.4/32
        in label:     16
        out label:    19        lsr: 10.0.0.2:0       inuse
        out label:    19        lsr: 10.0.0.3:0       inuse
  192.168.123.0/24
        in label:     imp-null
        out label:    imp-null  lsr: 10.0.0.2:0
        out label:    imp-null  lsr: 10.0.0.3:0
  192.168.234.0/24
        in label:     20
        out label:    imp-null  lsr: 10.0.0.2:0       inuse
        out label:    imp-null  lsr: 10.0.0.3:0       inuse
R1#

R1とR4をPEとし、R2,R3がPの場合、R1はiBGPを張るためにR4のLoopback 0だけ知ればよいので10.4.4.4にたいしてまでラベル付与する必要はない。

ACLでラベル付与対象経路を指定して、neighborで受信相手を指定する。

R1#conf t
R1(config)#access-list 1 permit 10.0.0.4 0.0.0.0
R1(config)#
R1(config)#mpls ldp neighbor 10.0.0.2 label accept 1
R1(config)#
R1(config)#end
R1#
R1#show mpls ip binding
  10.0.0.1/32
        in label:     imp-null
        out label:    18        lsr: 10.0.0.3:0
  10.0.0.2/32
        in label:     19
        out label:    17        lsr: 10.0.0.3:0
  10.0.0.3/32
        in label:     18
        out label:    imp-null  lsr: 10.0.0.3:0       inuse
  10.0.0.4/32
        in label:     17
        out label:    16        lsr: 10.0.0.2:0       inuse
        out label:    16        lsr: 10.0.0.3:0       inuse
  10.4.4.4/32
        in label:     16
        out label:    19        lsr: 10.0.0.3:0       inuse
  192.168.123.0/24
        in label:     imp-null
        out label:    imp-null  lsr: 10.0.0.3:0
  192.168.234.0/24
        in label:     20
        out label:    imp-null  lsr: 10.0.0.3:0       inuse
R1#

10.4.4.4/32の中にあった「lsr: 10.0.0.2:0」が消えている。指定しないネイバからの経路にはフィルタはされない。

送信ラベルフィルタリング

指定したネイバに特定のIGPエントリに対するラベルを通知する。

DIAGRAM

受信ラベルフィルタリングと同じ

CONFIG

受信ラベルフィルタリングと同じ

VERIFY

R2,R3いずれもR4からLoopback 0と4を受け取りimp-nullラベルを付与している。

R2#show mpls ip binding neighbor 10.0.0.4
  10.0.0.1/32
        out label:    18        lsr: 10.0.0.4:0
  10.0.0.2/32
        out label:    17        lsr: 10.0.0.4:0
  10.0.0.3/32
        out label:    16        lsr: 10.0.0.4:0
  10.0.0.4/32
        out label:    imp-null  lsr: 10.0.0.4:0       inuse
  10.4.4.4/32
        out label:    imp-null  lsr: 10.0.0.4:0       inuse
  192.168.123.0/24
        out label:    19        lsr: 10.0.0.4:0
  192.168.234.0/24
        out label:    imp-null  lsr: 10.0.0.4:0
R2#

R3#show mpls ip binding neighbor 10.0.0.4
  10.0.0.1/32
        out label:    18        lsr: 10.0.0.4:0
  10.0.0.2/32
        out label:    17        lsr: 10.0.0.4:0
  10.0.0.3/32
        out label:    16        lsr: 10.0.0.4:0
  10.0.0.4/32
        out label:    imp-null  lsr: 10.0.0.4:0       inuse
  10.4.4.4/32
        out label:    imp-null  lsr: 10.0.0.4:0       inuse
  192.168.123.0/24
        out label:    19        lsr: 10.0.0.4:0
  192.168.234.0/24
        out label:    imp-null  lsr: 10.0.0.4:0
R3#

R4はR2にLoopback0、R3にはLoopback4を送るようにしてみる。ACL10,14は経路、ACL2,3はネイバ。

R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#access-list 10 permit 10.0.0.4 0.0.0.0
R4(config)#access-list 14 permit 10.4.4.4 0.0.0.0
R4(config)#
R4(config)#access-list 2 permit 10.0.0.2 0.0.0.0
R4(config)#access-list 3 permit 10.0.0.3 0.0.0.0
R4(config)#
R4(config)#no mpls ldp advertise-labels
R4(config)#mpls ldp advertise-labels for 10 to 2
R4(config)#mpls ldp advertise-labels for 14 to 3
R4(config)#
R4(config)#end
R4#

結果はこのとおり。

R2#show mpls ip binding neighbor 10.0.0.4
  10.0.0.4/32
        out label:    imp-null  lsr: 10.0.0.4:0       inuse
R2#

R3#show mpls ip binding neighbor 10.0.0.4
  10.4.4.4/32
        out label:    imp-null  lsr: 10.0.0.4:0       inuse
R3#

送信フィルタリングの時には no mpls ldp advertise-labelsを忘れないこと。

 

 

コメント