Point-to-Point Protocol (PPP)

Point-to-Point Protocol (PPP)

NOTE

  • PPP有効
R1(config)#interface s1/0
R1(config-if)#encapsulation ppp

 

  • PAP認証
R1(config)#username R2 password cisco
R1(config)#
R1(config)#interface s1/0
R1(config-if)#ppp authentication pap
R1(config-if)#ppp pap sent-username R1 password cisco

 

  • CHAP認証
R1(config)#username R2 password cisco
R1(config)#
R1(config)#interface s1/0
R1(config-if)#ppp authentication chap

 

  • 確認
R1#show ppp all
Interface/ID OPEN+ Nego* Fail-     Stage    Peer Address    Peer Name
------------ --------------------- -------- --------------- --------------------
Se1/0        LCP+ CHAP+ IPCP+ CDP> LocalT   10.1.2.2        R2
R1#
R1#
R1#show ppp summary

                         Current     Peak
                        ---------  ---------
Non-MLP Sessions                1          1
MLP Sessions                    0          0
---------------------   ---------  ---------
Total Sessions                  1          1

                         Current     Peak
                        ---------  ---------
Non-MLP Links                   1          1
MLP Links                       0          0
---------------------   ---------  ---------
Total Links                     1          1

PPP Stage (links&bundles)   All Types   non-MLP      MLP
-------------------------   ---------  ---------  ---------
LCP Negotiation                     0          0          0
Unauthenticated Name                0          0          0
Authenticated Name                  0          0          0
No Authentication                   0          0          0
Post Authentication                 0          0          0
Forwarded                           0          0          0
Local Termination                   1          1          0
-------------------------   ---------  ---------  ---------
Total Curent                        1          1          0

                       ACK   ACK   REQ   Stop- Clos- Stop- Clos- Start-
Name     Total   Open  sent  rcvd  sent  ping  ing   ped   ed    ing   Initial
-------- ------ ------ ----- ----- ----- ----- ----- ----- ----- ----- -----
LCP           1      1     0     0     0     0     0     0     0     0     0
IPCP          1      1     0     0     0     0     0     0     0     0     0
CDPCP         1      1     0     0     0     0     0     0     0     0     0
R1#

 

  • IPアドレスをPPP Server側から割り当てる
!!! Server
R2(config)#ip local pool POOL-NAME 10.1.2.1 10.1.2.1
R2(config)#
R2(config)#interface Serial1/0
R2(config-if)#peer default ip address pool POOL-NAME
R2(config-if)#

!!! Client
R1(config)#interface Serial1/0
R1(config-if)#ip address negotiated

 

  • 対向のホストルートを持たない
R1(config-if)# no peer neighbor-route

 

  • デフォルトルートを登録する(明示的なstatic routeを制限された場合)
R1(config-if)# ppp ipcp route default

 

  • PPP Multilink
R1(config)#interface multilink 1
R1(config-if)#ip address 10.1.2.1 255.255.255.252
R1(config-if)# ppp multilink
R1(config-if)#
R1(config-if)#interface serial 1/0
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink group 1
R1(config-if)#
R1(config-if)#interface serial 1/1
R1(config-if)#encapsulation ppp
R1(config-if)#ppp multilink group 1
R1(config-if)#

R1#show ppp all
Interface/ID OPEN+ Nego* Fail-     Stage    Peer Address    Peer Name
------------ --------------------- -------- --------------- --------------------
Mu1          IPCP+ CDPCP+          LocalT   10.1.2.2
Se1/1        LCP+                  LocalT   10.1.2.2
Se1/0        LCP+                  LocalT   10.1.2.2
R1#
R1#
R1#show interfaces Multilink1
Multilink1 is up, line protocol is up
  Hardware is multilink group interface
  Internet address is 10.1.2.1/30
  MTU 1500 bytes, BW 3088 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open, multilink Open
  Open: IPCP, CDPCP, loopback not set
  Keepalive set (10 sec)

 

Point-to-Point Protocol over Ethernet (PPPoE)

NOTE

PPPoEは大きく分けて2ステージ

Discovery Stage

  1. PPPoE Active Discovery Initiation
    ブロードキャストでPPPoE SVを検索
    PPPoE CL —–> PPPoE SV
  2. PPPoE Active Discovery Offer
    SVからCLへ確認応答、SVが複数の可能性もある
    PPPoE CL <—– PPPoE SV
  3. PPPoE Active Discovery Request
    OfferをくれたSVにセッション開始要求
    PPPoE CL —–> PPPoE SV
  4. PPPoE Active Discovery Session-Confirmation
    SVが要求を受け入れた場合にセッションIDを通知
    SVが要求を拒否した場合はエラーパケット送信
    PPPoE CL <—– PPPoE SV

PPP Session Stage

  1. LCPネゴシエーション(PPPセッションの確立開始)
    PPPoE CL <—–> PPPoE SV
  2. 認証(PAP/CHAP)
    PPPoE CL <—–> PPPoE SV
  3. NCPネゴシエーション(IPCネゴシエーション)
    IPアドレスの要求、通知、割り当て
    PPPoE CL <—–> PPPoE SV
  4. PPPNCPネゴシエーション(IPCネゴシエーション)
    PPP通信
    PPPoE CL <—–> PPPoE SV

 

REFERENCE

コメント