スポンサーリンク

PPP IP address allocated from dhcp-pool

スポンサーリンク

TASK

PPPのアドレス割り当てはlocal poolかdhcp-pool
R1は自身のIFのアドレス帯とは異なるセグメントからでも割り当ててしまうのか?

DIAGRAM

 

CONFIG

hostname R1
!
ip dhcp excluded-address 10.1.2.1
ip dhcp excluded-address 192.168.12.1
!
ip dhcp pool DHCP-POOL-192
   network 192.168.12.0 255.255.255.0
   default-router 192.168.12.1
!
ip dhcp pool DHCP-POOL-10
   network 10.1.2.0 255.255.255.0
   default-router 10.1.2.1
!
interface Serial0/0
 ip address 10.1.2.1 255.255.255.0
 encapsulation ppp
 peer default ip address dhcp-pool DHCP-POOL-192
 no shutdown
!
end
hostname R2
!
interface Serial0/0
 ip address negotiated
 encapsulation ppp
 ppp ipcp route default
 shutdown
!
end

VERIFY

R2のIFを開放してみる

R1#sh ip int b | e una
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  10.1.2.1        YES manual up                    down
R2#sh ip int b | e una
Interface                  IP-Address      OK? Method Status                Protocol
R2#
R2#debug ppp nego
PPP protocol negotiation debugging is on
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int s0/0
R2(config-if)#no shut
R2(config-if)#
00:18:30: Se0/0 PPP: Outbound cdp packet dropped
R2(config-if)#
00:18:32: %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
00:18:32: Se0/0 PPP: Using default call direction
00:18:32: Se0/0 PPP: Treating connection as a dedicated line
00:18:32: Se0/0 PPP: Session handle[B7000002] Session id[2]
00:18:32: Se0/0 PPP: Phase is ESTABLISHING, Active Open
00:18:32: Se0/0 LCP: O CONFREQ [Closed] id 2 len 10
00:18:32: Se0/0 LCP:    MagicNumber 0x001CF99D (0x0506001CF99D)
00:18:32: Se0/0 LCP: I CONFREQ [REQsent] id 32 len 10
00:18:32: Se0/0 LCP:    MagicNumber 0x001D20F9 (0x0506001D20F9)
00:18:32: Se0/0 LCP: O CONFACK [REQsent] id 32 len 10
00:18:32: Se0/0 LCP:    MagicNumber 0x001D20F9 (0x0506001D20F9)
00:18:32: Se0/0 LCP: I CONFACK [ACKsent] id 2 len 10
00:18:32: Se0/0 LCP:    MagicNumber 0x001CF99D (0x0506001CF99D)
00:18:32: Se0/0 LCP: State is Open
00:18:32: Se0/0 PPP: Phase is FORWARDING, Attempting Forward
00:18:32: Se0/0 PPP: Phase is ESTABLISHING, Finish LCP
00:18:32: Se0/0 PPP: Phase is UP
00:18:32: Se0/0 IPCP: O CONFREQ [Closed] id 1 len 10
00:18:32: Se0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
00:18:32: Se0/0 CDPCP: O CONFREQ [Closed] id 1 len 4
00:18:32: Se0/0 PPP: Process pending ncp packets
00:18:32: Se0/0 CDPCP: I CONFREQ [REQsent] id 1 len 4
00:18:32: Se0/0 CDPCP: O CONFACK [REQsent] id 1 len 4
00:18:32: Se0/0 IPCP: I CONFREQ [REQsent] id 1 len 10
00:18:32: Se0/0 IPCP:    Address 10.1.2.1 (0x03060A010201)
00:18:32: Se0/0 IPCP: O CONFACK [REQsent] id 1 len 10
00:18:32: Se0/0 IPCP:    Address 10.1.2.1 (0x03060A010201)
00:18:32: Se0/0 CDPCP: I CONFACK [ACKsent] id 1 len 4
00:18:32: Se0/0 CDPCP: State is Open
00:18:33: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
00:18:34: Se0/0 IPCP: Timeout: State ACKsent
00:18:34: Se0/0 IPCP: O CONFREQ [ACKsent] id 2 len 10
00:18:34: Se0/0 IPCP:    Address 0.0.0.0 (0x030600000000)
00:18:34: Se0/0 IPCP: I CONFREQ [ACKsent] id 2 len 10
00:18:34: Se0/0 IPCP:    Address 10.1.2.1 (0x03060A010201)
00:18:34: Se0/0 IPCP: O CONFACK [ACKsent] id 2 len 10
00:18:34: Se0/0 IPCP:    Address 10.1.2.1 (0x03060A010201)
00:18:34: Se0/0 IPCP: I CONFNAK [ACKsent] id 1 len 10
00:18:34: Se0/0 IPCP:    Address 192.168.12.3 (0x0306C0A80C03)
00:18:34: Se0/0 IPCP: ID 1 didn't match 2, discarding packet
00:18:34: Se0/0 IPCP: I CONFNAK [ACKsent] id 2 len 10
00:18:34: Se0/0 IPCP:    Address 192.168.12.3 (0x0306C0A80C03)
00:18:34: Se0/0 IPCP: O CONFREQ [ACKsent] id 3 len 10
00:18:34: Se0/0 IPCP:    Address 192.168.12.3 (0x0306C0A80C03)
00:18:34: Se0/0 IPCP: I CONFACK [ACKsent] id 3 len 10
00:18:34: Se0/0 IPCP:    Address 192.168.12.3 (0x0306C0A80C03)
00:18:34: Se0/0 IPCP: State is Open
00:18:34: Se0/0 IPCP: Install negotiated IP interface address 192.168.12.3
00:18:34: Se0/0 IPCP: Install default route thru 10.1.2.1
00:18:34: Se0/0 IPCP: Install route to 10.1.2.1
R2(config-if)#
R2(config-if)#end
R2#sh ip i
00:18:45: %SYS-5-CONFIG_I: Configured from console by console
R2#sh ip int b | e una
Interface                  IP-Address      OK? Method Status                Protocol
Serial0/0                  192.168.12.3    YES IPCP   up                    up
R2#
R2#sh ip ro
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.1.2.1 to network 0.0.0.0

     192.168.12.0/32 is subnetted, 1 subnets
C       192.168.12.3 is directly connected, Serial0/0
     10.0.0.0/32 is subnetted, 1 subnets
C       10.1.2.1 is directly connected, Serial0/0
S*   0.0.0.0/0 [1/0] via 10.1.2.1
R2#

Ethernet のDHCPと違って異なるアドレス帯でも払い出せる

コメント