RIP default-information originate and route-map

NOTE

default-information originate 設定前

R1,R5,R7

router rip
 version 2
 network 10.0.0.0
 no auto-summary

デフォルトルートは無し

R5#show ip route 0.0.0.0
% Network not in table
R5#

R7#show ip route 0.0.0.0
% Network not in table
R7#

 

default-information originate 設定

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router rip
R1(config-router)#default-information originate
R1(config-router)#^Z

R5,R7 両方に広報

R5#show ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
  Known via "rip", distance 120, metric 1, candidate default path
  Redistributing via rip
  Last update from 10.1.5.1 on Ethernet1/0.15, 00:00:09 ago
  Routing Descriptor Blocks:
  * 10.1.5.1, from 10.1.5.1, 00:00:09 ago, via Ethernet1/0.15
      Route metric is 1, traffic share count is 1

R7#show ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
  Known via "rip", distance 120, metric 1, candidate default path
  Redistributing via rip
  Last update from 10.1.7.1 on Ethernet1/0.17, 00:00:23 ago
  Routing Descriptor Blocks:
  * 10.1.7.1, from 10.1.7.1, 00:00:23 ago, via Ethernet1/0.17
      Route metric is 1, traffic share count is 1

 

route-map set で広報相手を指定

R1 はR5 のみに広報する

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#route-map DEFAULT-ROUTE permit 10
R1(config-route-map)#set interface e1/0.15
%Warning:Use P2P interface for routemap setinterface clause

R1(config-route-map)#^Z
R1#
R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router rip
R1(config-router)#default-information originate route-map DEFAULT-ROUTE
R1(config-router)#^Z
R1#

R5 のみ受信

R5#show ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
  Known via "rip", distance 120, metric 1, candidate default path
  Redistributing via rip
  Last update from 10.1.5.1 on Ethernet1/0.15, 00:00:11 ago
  Routing Descriptor Blocks:
  * 10.1.5.1, from 10.1.5.1, 00:00:11 ago, via Ethernet1/0.15
      Route metric is 1, traffic share count is 1
R5#

R7#show ip route 0.0.0.0
% Network not in table
R7#

 

route-map match で広報条件を指定

R1 がR7から10.0.0.7/32 を受信している間だけR5 に広報する

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#route-map DEFAULT-ROUTE permit 10
R1(config-route-map)#match ip address prefix-list R7-LOOPBACK
R1(config-route-map)#exit
R1(config)#ip prefix-list R7-LOOPBACK s 10 permit 10.0.0.7/32
R1(config)#^Z
R1#
R1#show ip route 10.0.0.7
Routing entry for 10.0.0.7/32
  Known via "rip", distance 120, metric 1
  Redistributing via rip
  Last update from 10.1.7.7 on Ethernet1/0.17, 00:00:08 ago
  Routing Descriptor Blocks:
  * 10.1.7.7, from 10.1.7.7, 00:00:08 ago, via Ethernet1/0.17
      Route metric is 1, traffic share count is 1
R1#

まだこの時点では受信

R5#show ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
  Known via "rip", distance 120, metric 1, candidate default path
  Redistributing via rip
  Last update from 10.1.5.1 on Ethernet1/0.15, 00:00:18 ago
  Routing Descriptor Blocks:
  * 10.1.5.1, from 10.1.5.1, 00:00:18 ago, via Ethernet1/0.15
      Route metric is 1, traffic share count is 1
R5#

R7 のLoopback 0 をshutdown

R1#show ip route 10.0.0.7
% Subnet not in table
R1#

R5 も受信せず

R5#show ip route 0.0.0.0
% Network not in table
R5#

 

DIAGRAM & CONFIGURATION

コメント