Trouble Shooting Practice 05

TASK

次のOUTPUTが得られるようにしてください。

OUTPUT

R991#traceroute 192.168.99.2 so lo 0
Type escape sequence to abort.
Tracing the route to 192.168.99.2
VRF info: (vrf in name/id, vrf out name/id)
  1 172.16.3.1 48 msec 132 msec 124 msec
  2 172.16.4.1 [MPLS: Label 16 Exp 0] 128 msec 200 msec 128 msec
  3 172.16.4.2 200 msec 172 msec 224 msec
R991#

R992#traceroute 192.168.99.1 so lo 0
Type escape sequence to abort.
Tracing the route to 192.168.99.1
VRF info: (vrf in name/id, vrf out name/id)
  1 172.16.5.1 44 msec 88 msec 128 msec
  2 172.16.2.1 [MPLS: Label 16 Exp 0] 132 msec 128 msec 128 msec
  3 172.16.2.2 192 msec 184 msec 192 msec
R992#

DIAGRAM

CONFIG

hostname R1
!
no logging console
!
no ip domain lookup
ip cef
no ipv6 cef
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.2.1 255.255.255.252
 mpls ip
 no shutdown
!
interface FastEthernet1/0
 ip address 10.1.3.1 255.255.255.252
 mpls ip
 no shutdown
!
interface FastEthernet2/0
 ip address 10.1.4.1 255.255.255.252
 mpls ip
 no shutdown
!
interface FastEthernet3/0
 ip address 10.1.5.1 255.255.255.252
 mpls ip
 no shutdown
!
router eigrp CCIE
 !
 address-family ipv4 unicast autonomous-system 65000
  !
  af-interface default
   shutdown
  exit-af-interface
  !
  topology base
   redistribute connected route-map CON-INTO-EIGRP
  exit-af-topology
  network 10.1.2.1 0.0.0.0
  network 10.1.3.1 0.0.0.0
  network 10.1.4.1 0.0.0.0
  network 10.1.5.1 0.0.0.0
  eigrp router-id 10.0.0.1
 exit-address-family
!
router bgp 65000
 bgp router-id 10.0.0.1
 bgp cluster-id 10.0.0.1
 no bgp default ipv4-unicast
 timers bgp 15 45
 neighbor IBGP-PEER peer-group
 neighbor IBGP-PEER remote-as 65000
 neighbor IBGP-PEER update-source Loopback0
 neighbor 10.0.0.2 peer-group IBGP-PEER
 neighbor 10.0.0.3 peer-group IBGP-PEER
 neighbor 10.0.0.4 peer-group IBGP-PEER
 neighbor 10.0.0.5 peer-group IBGP-PEER
 !
 address-family ipv4
  neighbor IBGP-PEER route-reflector-client
  neighbor 10.0.0.2 activate
  neighbor 10.0.0.3 activate
  neighbor 10.0.0.4 activate
  neighbor 10.0.0.5 activate
 exit-address-family
 !
 address-family vpnv4
  neighbor IBGP-PEER send-community extended
  neighbor IBGP-PEER route-reflector-client
  neighbor 10.0.0.2 activate
  neighbor 10.0.0.3 activate
  neighbor 10.0.0.4 activate
  neighbor 10.0.0.5 activate
 exit-address-family
!
route-map CON-INTO-EIGRP deny 10
 match interface Loopback0
!
mpls ldp router-id Loopback0 force
!
end
hostname R2
!
no logging console
!
ip vrf VPN-USER-A
 rd 65000:99
 route-target export 65000:99
 route-target import 65000:99
!
no ip domain lookup
ip cef
no ipv6 cef
!
interface Loopback0
 ip address 10.0.0.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.2.2 255.255.255.252
 mpls ip
 no shutdown
!
interface FastEthernet1/0
 ip address 10.11.2.2 255.255.255.252
 mpls ip
 no shutdown
!
interface FastEthernet2/0
 ip vrf forwarding VPN-USER-A
 ip address 172.16.2.1 255.255.255.252
 no shutdown
!
router eigrp CCIE
 !
 address-family ipv4 unicast autonomous-system 65000
  !
  topology base
  exit-af-topology
  network 10.0.0.2 0.0.0.0
  network 10.1.2.2 0.0.0.0
  network 10.11.2.2 0.0.0.0
  eigrp router-id 10.0.0.2
 exit-address-family
!
router bgp 65000
 bgp router-id 10.0.0.2
 no bgp default ipv4-unicast
 timers bgp 15 45
 neighbor 10.0.0.1 remote-as 65000
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.0.0.11 remote-as 65000
 neighbor 10.0.0.11 update-source Loopback0
 !
 address-family ipv4
  neighbor 10.0.0.1 activate
  neighbor 10.0.0.1 next-hop-self
  neighbor 10.0.0.11 activate
  neighbor 10.0.0.11 next-hop-self
 exit-address-family
 !
 address-family vpnv4
  neighbor 10.0.0.1 activate
  neighbor 10.0.0.1 send-community extended
  neighbor 10.0.0.11 activate
  neighbor 10.0.0.11 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf VPN-USER-A
  neighbor 172.16.2.2 remote-as 65099
  neighbor 172.16.2.2 activate
  neighbor 172.16.2.2 as-override
  neighbor 172.16.2.2 soo 65000:991
 exit-address-family
!
mpls ldp router-id Loopback0 force
!
end
hostname R3
!
no logging console
!
ip vrf VPN-USER-A
 rd 65000:99
 route-target export 65000:99
 route-target import 65000:99
!
no ip domain lookup
ip cef
no ipv6 cef
!
interface Loopback0
 ip address 10.0.0.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.3.2 255.255.255.252
 mpls ip
 no shutdown
!
interface FastEthernet1/0
 ip address 10.11.3.2 255.255.255.252
 mpls ip
 no shutdown
!
interface FastEthernet2/0
 ip vrf forwarding VPN-USER-A
 ip address 172.16.3.1 255.255.255.252
 no shutdown
!
router eigrp CCIE
 !
 address-family ipv4 unicast autonomous-system 65000
  !
  topology base
  exit-af-topology
  network 10.0.0.3 0.0.0.0
  network 10.1.3.2 0.0.0.0
  network 10.11.3.2 0.0.0.0
  eigrp router-id 10.0.0.5
 exit-address-family
!
router bgp 65000
 bgp router-id 10.0.0.3
 no bgp default ipv4-unicast
 timers bgp 15 45
 neighbor 10.0.0.1 remote-as 65000
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.0.0.11 remote-as 65000
 neighbor 10.0.0.11 update-source Loopback0
 !
 address-family ipv4
  neighbor 10.0.0.1 activate
  neighbor 10.0.0.1 next-hop-self
  neighbor 10.0.0.11 activate
  neighbor 10.0.0.11 next-hop-self
 exit-address-family
 !
 address-family vpnv4
  neighbor 10.0.0.1 activate
  neighbor 10.0.0.1 send-community extended
  neighbor 10.0.0.11 activate
  neighbor 10.0.0.11 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf VPN-USER-A
  neighbor 172.16.3.2 remote-as 65099
  neighbor 172.16.3.2 activate
  neighbor 172.16.3.2 as-override
  neighbor 172.16.3.2 soo 65000:991
 exit-address-family
!
mpls ldp router-id Loopback0 force
!
end
hostname R4
!
no logging console
!
ip vrf VPN-USER-A
 rd 65000:99
 route-target export 65000:99
 route-target import 65000:99
!
no ip domain lookup
ip cef
no ipv6 cef
!
interface Loopback0
 ip address 10.0.0.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.4.2 255.255.255.252
 mpls ip
 no shutdown
!
interface FastEthernet1/0
 ip address 10.11.4.2 255.255.255.252
 mpls ip
 no shutdown
!
interface FastEthernet2/0
 ip vrf forwarding VPN-USER-A
 ip address 172.16.4.1 255.255.255.252
 no shutdown
!
router eigrp CCIE
 !
 address-family ipv4 unicast autonomous-system 65000
  !
  topology base
  exit-af-topology
  network 10.0.0.4 0.0.0.0
  network 10.1.4.2 0.0.0.0
  network 10.11.4.2 0.0.0.0
  eigrp router-id 10.0.0.4
 exit-address-family
!
router bgp 65000
 bgp router-id 10.0.0.4
 no bgp default ipv4-unicast
 timers bgp 15 45
 neighbor 10.0.0.1 remote-as 65000
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.0.0.11 remote-as 65000
 neighbor 10.0.0.11 update-source Loopback0
 !
 address-family ipv4
  neighbor 10.0.0.1 activate
  neighbor 10.0.0.1 next-hop-self
  neighbor 10.0.0.11 activate
  neighbor 10.0.0.11 next-hop-self
 exit-address-family
 !
 address-family vpnv4
  neighbor 10.0.0.1 activate
  neighbor 10.0.0.1 send-community extended
  neighbor 10.0.0.11 activate
  neighbor 10.0.0.11 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf VPN-USER-A
  neighbor 172.16.4.2 remote-as 65099
  neighbor 172.16.4.2 activate
  neighbor 172.16.4.2 as-override
  neighbor 172.16.4.2 soo 65000:991
 exit-address-family
!
mpls ldp router-id Loopback0 force
!
end
hostname R5
!
no logging console
!
ip vrf VPN-USER-A
 rd 65000:99
 route-target export 65000:99
 route-target import 65000:99
!
no ip domain lookup
ip cef
no ipv6 cef
!
interface Loopback0
 ip address 10.0.0.5 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.5.2 255.255.255.252
 mpls ip
 no shutdown
!
interface FastEthernet1/0
 ip address 10.11.5.2 255.255.255.252
 mpls ip
 no shutdown
!
interface FastEthernet2/0
 ip vrf forwarding VPN-USER-A
 ip address 172.16.5.1 255.255.255.252
 no shutdown
!
router eigrp CCIE
 !
 address-family ipv4 unicast autonomous-system 65000
  !
  topology base
  exit-af-topology
  network 10.0.0.5 0.0.0.0
  network 10.1.5.2 0.0.0.0
  network 10.11.5.2 0.0.0.0
  eigrp router-id 10.0.0.5
 exit-address-family
!
router bgp 65000
 bgp router-id 10.0.0.5
 no bgp default ipv4-unicast
 timers bgp 15 45
 neighbor 10.0.0.1 remote-as 65000
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.0.0.11 remote-as 65000
 neighbor 10.0.0.11 update-source Loopback0
 !
 address-family ipv4
  neighbor 10.0.0.1 activate
  neighbor 10.0.0.1 next-hop-self
  neighbor 10.0.0.11 activate
  neighbor 10.0.0.11 next-hop-self
 exit-address-family
 !
 address-family vpnv4
  neighbor 10.0.0.1 activate
  neighbor 10.0.0.1 send-community extended
  neighbor 10.0.0.11 activate
  neighbor 10.0.0.11 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf VPN-USER-A
  neighbor 172.16.5.2 remote-as 65099
  neighbor 172.16.5.2 activate
  neighbor 172.16.5.2 as-override
  neighbor 172.16.5.2 soo 65000:991
 exit-address-family
!
mpls ldp router-id Loopback0 force
!
end
hostname R11
!
no logging console
!
no ip domain lookup
ip cef
no ipv6 cef
!
interface Loopback0
 ip address 10.0.0.11 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.11.2.1 255.255.255.252
 mpls ip
 no shutdown
!
interface FastEthernet1/0
 ip address 10.11.3.1 255.255.255.252
 mpls ip
 no shutdown
!
interface FastEthernet2/0
 ip address 10.11.4.1 255.255.255.252
 mpls ip
 no shutdown
!
interface FastEthernet3/0
 ip address 10.11.5.1 255.255.255.252
 mpls ip
 no shutdown
!
router eigrp CCIE
 !
 address-family ipv4 unicast autonomous-system 65000
  !
  topology base
   redistribute connected route-map CON-INTO-EIGRP
  exit-af-topology
  network 10.11.2.1 0.0.0.0
  network 10.11.3.1 0.0.0.0
  network 10.11.4.1 0.0.0.0
  network 10.11.5.1 0.0.0.0
  eigrp router-id 10.0.0.11
 exit-address-family
!
router bgp 65000
 bgp router-id 10.0.0.11
 bgp cluster-id 10.0.0.1
 no bgp default ipv4-unicast
 timers bgp 15 45
 neighbor IBGP-PEER peer-group
 neighbor IBGP-PEER remote-as 65000
 neighbor IBGP-PEER update-source Loopback0
 neighbor 10.0.0.2 peer-group IBGP-PEER
 neighbor 10.0.0.3 peer-group IBGP-PEER
 neighbor 10.0.0.4 peer-group IBGP-PEER
 neighbor 10.0.0.5 peer-group IBGP-PEER
 !
 address-family ipv4
  neighbor IBGP-PEER route-reflector-client
  neighbor 10.0.0.2 activate
  neighbor 10.0.0.3 activate
  neighbor 10.0.0.4 activate
  neighbor 10.0.0.5 activate
 exit-address-family
 !
 address-family vpnv4
  neighbor IBGP-PEER send-community extended
  neighbor IBGP-PEER route-reflector-client
  neighbor 10.0.0.2 activate
  neighbor 10.0.0.3 activate
  neighbor 10.0.0.4 activate
  neighbor 10.0.0.5 activate
 exit-address-family
!
route-map CON-INTO-EIGRP permit 10
 match interface Loopback0
!
mpls ldp router-id Loopback0 force
!
end
hostname R991
!
no logging console
!
no ip domain lookup
ip cef
no ipv6 cef
!
interface Loopback0
 ip address 192.168.99.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 172.16.2.2 255.255.255.252
 no shutdown
!
interface FastEthernet1/0
 ip address 172.16.3.2 255.255.255.252
 no shutdown
!
router bgp 65099
 bgp router-id 192.168.99.1
 network 192.168.99.1 mask 255.255.255.255
 neighbor 172.16.2.1 remote-as 65000
 neighbor 172.16.2.1 route-map SET-MED-R2 out
 neighbor 172.16.3.1 remote-as 65000
 neighbor 172.16.3.1 weight 40000
 neighbor 172.16.3.1 route-map SET-MED-R3 out
!
ip prefix-list LOOPBACK-ROUTE seq 10 permit 192.168.99.1/32
!
route-map SET-MED-R2 permit 10
 match ip address prefix-list LOOPBACK-ROUTE
 set metric 10
!
route-map SET-MED-R2 permit 1000
!
route-map SET-MED-R3 permit 10
 match ip address prefix-list LOOPBACK-ROUTE
 set metric 20
!
route-map SET-MED-R3 permit 1000
!
end
hostname R992
!
no logging console
!
no ip domain lookup
ip cef
no ipv6 cef
!
interface Loopback0
 ip address 192.168.99.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 172.16.4.2 255.255.255.252
 no shutdown
!
interface FastEthernet1/0
 ip address 172.16.5.2 255.255.255.252
 no shutdown
!
router bgp 65099
 bgp router-id 192.168.99.2
 network 192.168.99.2 mask 255.255.255.255
 neighbor 172.16.4.1 remote-as 65000
 neighbor 172.16.4.1 route-map SET-MED-R4 out
 neighbor 172.16.5.1 remote-as 65000
 neighbor 172.16.5.1 weight 40000
 neighbor 172.16.5.1 route-map SET-MED-R5 out
!
ip prefix-list LOOPBACK-ROUTE seq 10 permit 192.168.99.2/32
!
route-map SET-MED-R4 permit 10
 match ip address prefix-list LOOPBACK-ROUTE
 set metric 10
!
route-map SET-MED-R4 permit 1000
!
route-map SET-MED-R5 permit 10
 match ip address prefix-list LOOPBACK-ROUTE
 set metric 20
!
route-map SET-MED-R5 permit 1000
!
end

SOLUTION

SOLUTION

コメント