Trouble Shooting Practice 06

TASK

次のOUTPUTが得られるようにしてください。

OUTPUT

R6#ping 10.0.0.7 so lo 0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.7, timeout is 2 seconds:
Packet sent with a source address of 10.0.0.6
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/28/40 ms
R6#
R6#ping 172.16.1.1 so lo 0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
Packet sent with a source address of 10.0.0.6
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/28/48 ms
R6#

DIAGRAM

 

CONFIG

hostname R1
!
no logging console
!
no ip domain lookup
ip cef
no ipv6 cef
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface Loopback172
 ip address 172.16.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.2.1 255.255.255.252
 no shutdown
!
interface FastEthernet1/0
 ip address 10.1.3.1 255.255.255.252
 no shutdown
!
router eigrp 65000
 metric weights 0 0 0 1 0 0
 network 10.1.2.1 0.0.0.0
 network 10.1.3.1 0.0.0.0
 redistribute connected route-map CON-INTO-EIGRP
 eigrp router-id 10.0.0.1
!
router bgp 65000
 bgp router-id 10.0.0.1
 timers bgp 15 45
 neighbor IBGP-PEER peer-group
 neighbor IBGP-PEER remote-as 65000
 neighbor 10.0.0.2 peer-group IBGP-PEER
 neighbor 10.0.0.3 peer-group IBGP-PEER
 neighbor 10.0.0.4 peer-group IBGP-PEER
 neighbor 10.0.0.5 peer-group IBGP-PEER
 !
 address-family ipv4
  aggregate-address 172.16.0.0 255.255.0.0 as-set summary-only
  neighbor IBGP-PEER send-community both
  neighbor IBGP-PEER route-reflector-client
  neighbor 10.0.0.2 activate
  neighbor 10.0.0.3 activate
  neighbor 10.0.0.4 activate
  neighbor 10.0.0.5 activate
 exit-address-family
!
ip bgp-community new-format
!
route-map CON-INTO-EIGRP permit 10
 match interface Loopback0
!
end
hostname R2
!
no logging console
!
no ip domain lookup
ip cef
no ipv6 cef
!
interface Loopback0
 ip address 10.0.0.2 255.255.255.255
!
interface Loopback172
 ip address 172.16.2.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.1.2.2 255.255.255.252
 no shutdown
!
interface FastEthernet1/0
 ip address 10.2.4.1 255.255.255.252
 no shutdown
!
interface FastEthernet2/0
 ip address 10.2.3.1 255.255.255.252
 no shutdown
!
router eigrp 65000
 metric weights 0 0 0 1 0 0
 network 10.0.0.2 0.0.0.0
 network 10.1.2.2 0.0.0.0
 network 10.2.3.1 0.0.0.0
 network 10.2.4.1 0.0.0.0
 eigrp router-id 10.0.0.2
!
router bgp 65000
 bgp router-id 10.0.0.2
 timers bgp 15 45
 neighbor 10.0.0.1 remote-as 65000
 neighbor 10.0.0.1 update-source Loopback0
 !
 address-family ipv4
  network 172.16.2.0 mask 255.255.255.0
  neighbor 10.0.0.1 activate
  neighbor 10.0.0.1 send-community both
  neighbor 10.0.0.1 route-map COMMUNITY out
 exit-address-family
!
ip bgp-community new-format
!
route-map COMMUNITY permit 10
 set community no-export
!
end
hostname R3
!
no logging console
!
no ip domain lookup
ip cef
no ipv6 cef
!
interface Loopback0
 ip address 10.0.0.3 255.255.255.255
!
interface Loopback172
 ip address 172.16.3.3 255.255.255.0
!
interface FastEthernet0/0
 ip address 10.1.3.2 255.255.255.252
 no shutdown
!
interface FastEthernet1/0
 ip address 10.3.5.1 255.255.255.252
 no shutdown
!
interface FastEthernet2/0
 ip address 10.2.3.2 255.255.255.252
 no shutdown
!
router eigrp 65000
 metric weights 0 0 0 1 0 0
 network 10.0.0.3 0.0.0.0
 network 10.1.3.2 0.0.0.0
 network 10.2.3.2 0.0.0.0
 redistribute ospf 65000 metric 100 10 255 1 1500 route-map OSPF-INTO-EIGRP
 eigrp router-id 10.0.0.3
!
router ospf 65000
 router-id 10.0.0.3
 redistribute eigrp 65000 subnets route-map EIGRP-INTO-OSPF
 network 10.3.5.1 0.0.0.0 area 0
!
router bgp 65000
 bgp router-id 10.0.0.3
 timers bgp 15 45
 neighbor 10.0.0.1 remote-as 65000
 neighbor 10.0.0.1 update-source Loopback0
 !
 address-family ipv4
  network 172.16.3.0 mask 255.255.255.0
  neighbor 10.0.0.1 activate
  neighbor 10.0.0.1 send-community both
  neighbor 10.0.0.1 route-map COMMUNITY out
 exit-address-family
!
ip bgp-community new-format
!
ip prefix-list TYPE-2-ROUTE seq 10 permit 10.0.0.4/32
!
route-map COMMUNITY permit 10
 set community none
!
route-map EIGRP-INTO-OSPF deny 10
 match tag 54
!
route-map EIGRP-INTO-OSPF permit 20
 match ip address prefix-list TYPE-2-ROUTE
 set metric-type type-2
!
route-map EIGRP-INTO-OSPF permit 1000
 set metric-type type-1
!
route-map OSPF-INTO-EIGRP permit 10
 set tag 53
!
end
hostname R4
!
no logging console
!
no ip domain lookup
ip cef
no ipv6 cef
!
interface Loopback0
 ip address 10.0.0.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.2.4.2 255.255.255.252
 no shutdown
!
interface FastEthernet1/0
 ip address 10.4.6.1 255.255.255.252
 no shutdown
!
interface FastEthernet2/0
 ip address 10.4.5.1 255.255.255.252
 no shutdown
!
router eigrp 65000
 metric weights 0 0 0 1 0 0
 network 10.0.0.4 0.0.0.0
 network 10.2.4.2 0.0.0.0
 redistribute ospf 65000 metric 100 10 255 1 1500 route-map OSPF-INTO-EIGRP
 eigrp router-id 10.0.0.4
!
router ospf 65000
 router-id 10.0.0.4
 redistribute eigrp 65000 subnets route-map EIGRP-INTO-OSPF
 network 10.4.5.1 0.0.0.0 area 0
!
router bgp 65000
 bgp router-id 10.0.0.4
 timers bgp 15 45
 neighbor 10.0.0.1 remote-as 65000
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.4.6.2 remote-as 65006
 !
 address-family ipv4
  neighbor 10.0.0.1 activate
  neighbor 10.0.0.1 send-community both
  neighbor 10.0.0.1 next-hop-self
  neighbor 10.4.6.2 activate
  neighbor 10.4.6.2 route-map COMMUNITY in
 exit-address-family
!
ip bgp-community new-format
!
ip prefix-list TYPE-1-ROUTE seq 10 permit 10.0.0.4/32
!
route-map COMMUNITY permit 10
 set community 65000:999
!
route-map EIGRP-INTO-OSPF deny 10
 match tag 53 54
!
route-map EIGRP-INTO-OSPF permit 20
 match ip address prefix-list TYPE-1-ROUTE
 set metric-type type-1
!
route-map EIGRP-INTO-OSPF permit 1000
 set metric-type type-2
!
route-map OSPF-INTO-EIGRP permit 10
 set tag 54
!
end
hostname R5
!
no logging console
!
no ip domain lookup
ip cef
no ipv6 cef
!
interface Loopback0
 ip address 10.0.0.5 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.3.5.2 255.255.255.252
 no shutdown
!
interface FastEthernet1/0
 ip address 10.5.7.1 255.255.255.252
 no shutdown
!
interface FastEthernet2/0
 ip address 10.4.5.2 255.255.255.252
 no shutdown
!
router ospf 65000
 router-id 10.0.0.5
 network 10.0.0.5 0.0.0.0 area 0
 network 10.3.5.2 0.0.0.0 area 0
 network 10.4.5.2 0.0.0.0 area 0
!
router bgp 65000
 bgp router-id 10.0.0.5
 timers bgp 15 45
 neighbor 10.0.0.1 remote-as 65000
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.5.7.2 remote-as 65007
 !
 address-family ipv4
  neighbor 10.0.0.1 activate
  neighbor 10.0.0.1 send-community both
  neighbor 10.0.0.1 route-map SET-NH in
  neighbor 10.5.7.2 activate
  neighbor 10.5.7.2 route-map COMMUNITY in
 exit-address-family
!
ip bgp-community new-format
!
route-map COMMUNITY permit 10
 set community 65000:999
!
route-map SET-NH permit 10
 set ip next-hop peer-address
!
end
hostname R6
!
no logging console
!
no ip domain lookup
ip cef
no ipv6 cef
!
interface Loopback0
 ip address 10.0.0.6 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.4.6.2 255.255.255.252
 no shutdown
!
interface FastEthernet1/0
 no ip address
 shutdown
!
router bgp 65006
 bgp router-id 10.0.0.6
 network 10.0.0.6 mask 255.255.255.255
 neighbor 10.4.6.1 remote-as 65000
!
ip bgp-community new-format
!
end
hostname R7
!
no logging console
!
no ip domain lookup
ip cef
no ipv6 cef
!
interface Loopback0
 ip address 10.0.0.7 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.5.7.2 255.255.255.252
 no shutdown
!
interface FastEthernet1/0
 no ip address
 shutdown
!
router bgp 65007
 bgp router-id 10.0.0.7
 network 10.0.0.7 mask 255.255.255.255
 neighbor 10.5.7.1 remote-as 65000
!
ip bgp-community new-format
!
end

SOLUTION

Trouble Shooting Practice 06 Solution

 

コメント