Trouble Shooting Practice 07

TASK

R114と192.168.103.0の間でR3-R103を経由して通信ができるようにしなさい。
R114と192.168.105.0の間でR5-R105を経由して通信ができるようにしなさい。
それぞれの区間で障害が起きた場合は残りの回線を使って迂回しなさい。
AS65000内では通常時はR1-R2を使い、R3-R2はバックアップとして利用しなさい。

DIAGRAM

 

CONFIG

hostname R1
!
no logging console
!
no ip domain lookup
ip cef
ipv6 cef
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
 ip ospf 65000 area 0
!
interface FastEthernet0/0
 ip address 10.1.2.1 255.255.255.252
 no shutdown
!
interface FastEthernet1/0
 ip address 10.1.3.1 255.255.255.252
 ip ospf 65000 area 0
 no shutdown
!
interface FastEthernet2/0
 ip address 10.1.4.1 255.255.255.252
 shutdown
!
interface FastEthernet3/0
 ip address 10.1.5.1 255.255.255.252
 ip ospf 65000 area 0
 no shutdown
!
router ospf 65000
 router-id 10.0.0.1
!
router bgp 65135
 bgp router-id 10.0.0.1
 bgp confederation identifier 65000
 timers bgp 15 45
 neighbor IBGP-PEER peer-group
 neighbor IBGP-PEER remote-as 65135
 neighbor IBGP-PEER update-source Loopback0
 neighbor IBGP-PEER route-reflector-client
 neighbor IBGP-PEER next-hop-self
 neighbor 10.0.0.3 peer-group IBGP-PEER
 neighbor 10.0.0.5 peer-group IBGP-PEER
 neighbor 10.1.2.2 remote-as 65246
 neighbor 10.1.2.2 route-map SET-LP in
!
route-map SET-LP permit 10
 set local-preference 100
!
end
hostname R2
!
no logging console
!
no ip domain lookup
ip cef
ipv6 cef
!
interface Loopback0
 ip address 10.0.0.2 255.255.255.255
 ip ospf 65000 area 0
!
interface FastEthernet0/0
 ip address 10.1.2.2 255.255.255.252
 no shutdown
!
interface FastEthernet1/0
 ip address 10.2.4.1 255.255.255.252
 ip ospf 65000 area 0
 no shutdown
!
interface FastEthernet2/0
 ip address 10.2.3.1 255.255.255.252
 no shutdown
!
interface FastEthernet3/0
 ip address 10.2.6.1 255.255.255.252
 ip ospf 65000 area 0
 no shutdown
!
router ospf 65000
 router-id 10.0.0.2
!
router bgp 65246
 bgp router-id 10.0.0.2
 bgp confederation identifier 65000
 timers bgp 15 45
 neighbor IBGP-PEER peer-group
 neighbor IBGP-PEER remote-as 65246
 neighbor IBGP-PEER update-source Loopback0
 neighbor IBGP-PEER route-reflector-client
 neighbor IBGP-PEER next-hop-self
 neighbor 10.0.0.4 peer-group IBGP-PEER
 neighbor 10.0.0.6 peer-group IBGP-PEER
 neighbor 10.1.2.1 remote-as 65135
 neighbor 10.1.2.1 weight 40000
 neighbor 10.2.3.2 remote-as 65135
!
end
hostname R3
!
no logging console
!
no ip domain lookup
ip cef
ipv6 cef
!
interface Loopback0
 ip address 10.0.0.3 255.255.255.255
 ip ospf 65000 area 0
!
interface FastEthernet0/0
 ip address 10.1.3.2 255.255.255.252
 ip ospf 65000 area 0
 no shutdown
!
interface FastEthernet1/0
 ip address 10.2.3.2 255.255.255.252
 no shutdown
!
interface FastEthernet2/0
 ip address 10.3.5.1 255.255.255.252
 ip ospf 65000 area 0
 no shutdown
!
interface FastEthernet3/0
 ip address 172.16.33.1 255.255.255.252
 no shutdown
!
router ospf 65000
 router-id 10.0.0.3
!
router bgp 65135
 bgp router-id 10.0.0.3
 bgp confederation identifier 65000
 timers bgp 15 45
 redistribute connected route-map CON-INTO-BGP
 neighbor 10.0.0.1 remote-as 65135
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.0.0.1 next-hop-self
 neighbor 10.2.3.1 remote-as 65246
 neighbor 10.2.3.1 route-map SET-LP in
 neighbor 172.16.33.2 remote-as 65035
!
route-map CON-INTO-BGP permit 10
 match interface FastEthernet3/0
!
route-map SET-LP permit 10
 set local-preference 200
!
end
hostname R4
!
no logging console
!
no ip domain lookup
ip cef
ipv6 cef
!
interface Loopback0
 ip address 10.0.0.4 255.255.255.255
 ip ospf 65000 area 0
!
interface FastEthernet0/0
 ip address 10.2.4.2 255.255.255.252
 ip ospf 65000 area 0
 no shutdown
!
interface FastEthernet1/0
 ip address 10.1.4.2 255.255.255.252
 shutdown
!
interface FastEthernet2/0
 ip address 10.4.6.1 255.255.255.252
 ip ospf 65000 area 0
 no shutdown
!
interface FastEthernet3/0
 ip address 172.16.44.1 255.255.255.252
 no shutdown
!
router ospf 65000
 router-id 10.0.0.4
!
router bgp 65246
 bgp router-id 10.0.0.4
 bgp confederation identifier 65000
 timers bgp 15 45
 redistribute connected route-map CON-INTO-BGP
 redistribute static route-map STATIC-INTO-BGP
 neighbor 10.0.0.2 remote-as 65246
 neighbor 10.0.0.2 update-source Loopback0
 neighbor 10.0.0.2 next-hop-self
!
ip route 192.168.0.104 255.255.255.255 172.16.44.2
ip route 192.168.104.0 255.255.255.0 172.16.44.2
!
ip prefix-list R104-ROUTE seq 10 permit 192.168.0.104/32
ip prefix-list R104-ROUTE seq 20 permit 192.168.104.0/24
!
route-map CON-INTO-BGP permit 10
 match interface FastEthernet3/0
!
route-map STATIC-INTO-BGP permit 10
 match ip address prefix-list R104-ROUTE
!
end
hostname R5
!
no logging console
!
no ip domain lookup
ip cef
ipv6 cef
!
interface Loopback0
 ip address 10.0.0.5 255.255.255.255
 ip ospf 65000 area 0
!
interface FastEthernet0/0
 ip address 10.1.5.2 255.255.255.252
 ip ospf 65000 area 0
 no shutdown
!
interface FastEthernet1/0
 no ip address
 shutdown
!
interface FastEthernet2/0
 ip address 10.3.5.2 255.255.255.252
 ip ospf 65000 area 0
 no shutdown
!
interface FastEthernet3/0
 ip address 172.16.55.1 255.255.255.252
 no shutdown
!
router ospf 65000
 router-id 10.0.0.5
!
router bgp 65135
 bgp router-id 10.0.0.5
 bgp confederation identifier 65000
 timers bgp 15 45
 redistribute connected route-map CON-INTO-BGP
 neighbor 10.0.0.1 remote-as 65135
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.0.0.1 next-hop-self
 neighbor 172.16.55.2 remote-as 65035
!
route-map CON-INTO-BGP permit 10
 match interface FastEthernet3/0
!
end
hostname R6
!
no logging console
!
no ip domain lookup
ip cef
ipv6 cef
!
interface Loopback0
 ip address 10.0.0.6 255.255.255.255
 ip ospf 65000 area 0
!
interface FastEthernet0/0
 ip address 10.2.6.2 255.255.255.252
 ip ospf 65000 area 0
 no shutdown
!
interface FastEthernet1/0
 no ip address
 shutdown
!
interface FastEthernet2/0
 ip address 10.4.6.2 255.255.255.252
 ip ospf 65000 area 0
 no shutdown
!
interface FastEthernet3/0
 ip address 172.16.66.1 255.255.255.252
 no shutdown
!
router ospf 65000
 router-id 10.0.0.6
!
router bgp 65246
 bgp router-id 10.0.0.6
 bgp confederation identifier 65000
 timers bgp 15 45
 neighbor 10.0.0.2 remote-as 65246
 neighbor 10.0.0.2 update-source Loopback0
 neighbor 10.0.0.2 next-hop-self
!
end
hostname R103
!
no logging console
!
ip dhcp pool OFFICE-LAN
 host 192.168.104.114 255.255.255.0
 client-identifier 00cc.1ecc.1ecc.1e
 default-router 192.168.104.104
!
no ip domain lookup
ip cef
ipv6 cef
!
interface Loopback0
 ip address 192.168.0.103 255.255.255.255
!
interface FastEthernet0/0
 ip address 172.16.33.2 255.255.255.252
 no shutdown
!
interface FastEthernet1/0
 ip address 192.168.103.103 255.255.255.0
 no keepalive
 no shutdown
!
interface Serial2/0
 ip address 192.168.35.1 255.255.255.252
 encapsulation ppp
 serial restart-delay 0
 no shutdown
!
router ospf 65035
 router-id 192.168.0.103
 network 192.168.0.103 0.0.0.0 area 0
 network 192.168.35.1 0.0.0.0 area 0
 network 192.168.103.103 0.0.0.0 area 0
!
router bgp 65035
 bgp router-id 192.168.0.103
 timers bgp 15 45
 redistribute ospf 65035
 neighbor 172.16.33.1 remote-as 65000
 neighbor 172.16.33.1 prefix-list ADV-ROUTE out
 neighbor 172.16.33.1 route-map SET-MED out
 neighbor 192.168.0.105 remote-as 65035
 neighbor 192.168.0.105 update-source Loopback0
 neighbor 192.168.0.105 next-hop-self
!
ip prefix-list ADV-ROUTE seq 10 permit 192.168.0.103/32
ip prefix-list ADV-ROUTE seq 20 permit 192.168.0.105/32
ip prefix-list ADV-ROUTE seq 30 permit 192.168.35.0/30
ip prefix-list ADV-ROUTE seq 40 permit 192.168.13.0/24
ip prefix-list ADV-ROUTE seq 50 permit 192.168.105.0/24
!
ip prefix-list R103-LAN seq 10 permit 192.168.0.103/32
ip prefix-list R103-LAN seq 20 permit 192.168.103.0/24
!
route-map SET-MED permit 10
 match ip address prefix-list R103-LAN
 set metric 100
!
route-map SET-MED permit 20
 set metric 200
!
end
hostname R104
!
no logging console
!
no ip domain lookup
ip cef
ipv6 cef
!
interface Loopback0
 ip address 192.168.0.104 255.255.255.255
!
interface FastEthernet0/0
 ip address 172.16.44.2 255.255.255.252
 no shutdown
!
interface FastEthernet1/0
 ip address 192.168.104.104 255.255.255.0
 ip helper-address 192.168.0.103
 no keepalive
 no shutdown
!
ip route 0.0.0.0 0.0.0.0 172.16.44.1
!
end
hostname R105
!
no logging console
!
no ip domain lookup
ip cef
ipv6 cef
!
!
interface Loopback0
 ip address 192.168.0.105 255.255.255.255
!
interface FastEthernet0/0
 ip address 172.16.55.2 255.255.255.252
 no shutdown
!
interface FastEthernet1/0
 ip address 192.168.105.105 255.255.255.0
 no keepalive
 no shutdown
!
interface Serial2/0
 ip address 192.168.35.2 255.255.255.252
 encapsulation ppp
 serial restart-delay 0
 no shutdown
!
router ospf 65035
 router-id 192.168.0.105
 network 192.168.0.105 0.0.0.0 area 0
 network 192.168.35.2 0.0.0.0 area 0
 network 192.168.105.105 0.0.0.0 area 0
!
router bgp 65035
 bgp router-id 192.168.0.105
 timers bgp 15 45
 redistribute ospf 65035
 neighbor 172.16.55.1 remote-as 65000
 neighbor 172.16.55.1 prefix-list ADV-ROUTE out
 neighbor 172.16.55.1 route-map SET-MED out
 neighbor 192.168.0.103 remote-as 65035
 neighbor 192.168.0.103 update-source Loopback0
 neighbor 192.168.0.103 next-hop-self
!
ip prefix-list ADV-ROUTE seq 10 permit 192.168.0.103/32
ip prefix-list ADV-ROUTE seq 20 permit 192.168.0.105/32
ip prefix-list ADV-ROUTE seq 30 permit 192.168.35.0/30
ip prefix-list ADV-ROUTE seq 40 permit 192.168.103.0/24
ip prefix-list ADV-ROUTE seq 50 permit 192.168.150.0/24
!
ip prefix-list R105-LAN seq 10 permit 192.168.0.105/32
ip prefix-list R105-LAN seq 20 permit 192.168.105.0/24
!
route-map SET-MED permit 10
 match ip address prefix-list R105-LAN
 set metric 100
!
route-map SET-MED permit 20
 set metric 200
!
end
hostname R114
!
no logging console
!
no ip domain lookup
ip cef
ipv6 cef
!
interface FastEthernet0/0
 mac-address cc1e.cc1e.cc1e
 ip address dhcp client-id FastEthernet0/0 hostname R114
 no shutdown
!
end

SOLUTION

Trouble Shooting Practice 07 Solution

 

コメント