EIGRP Auto-Summary

NOTE

  • auto-summary は外部経路は集約しない
  • 内部経路があれば外部経路も集約される

 

 

R1#sh ip int b | e una
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet1/0            192.168.12.1    YES manual up                    up

R1#sh run | sec router eigrp
router eigrp 65000
 network 192.168.12.1 0.0.0.0
 eigrp router-id 10.0.0.1

R2#sh ip int b | e una
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.12.2    YES manual up                    up
FastEthernet1/0            192.168.23.2    YES manual up                    up

R2#sh run | sec router eigrp
router eigrp 65000
 network 192.168.12.2 0.0.0.0
 network 192.168.23.2 0.0.0.0
 eigrp router-id 10.0.0.2
R2#

R3#sh ip int b | e una
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.23.3    YES manual up                    up
FastEthernet1/0            10.3.3.3        YES manual up                    up
Loopback0                  10.0.0.3        YES manual up                    up

R3#sh run | sec router eigrp
router eigrp 65000
 network 192.168.23.3 0.0.0.0
 auto-summary
 eigrp router-id 10.0.0.3
R3#

 

変更前

R2 ではEIGRP 経路は受信せず

R2#sh ip ro ei | b Gate
Gateway of last resort is not set

R2#

 

R3 でauto-summary

route-map でLoopback0 を再配送

R3(config)#route-map CON-INTO-EIGRP
R3(config-route-map)#match int lo 0
R3(config-route-map)#
R3(config-route-map)#router ei 65000
R3(config-router)#redist con route-map CON-INTO-EIGRP
R3(config-router)#

 

auto-summary があっても、R3 には有効な内部経路が無いので集約はされない

R2#sh ip ro ei | b Gate
Gateway of last resort is not set

      10.0.0.0/32 is subnetted, 1 subnets
D EX     10.0.0.3 [170/156160] via 192.168.23.3, 00:01:53, FastEthernet1/0
R2#

 

同時に外部経路と同じ10.台でEIGRP を有効にしてみる

R3(config)#route-map CON-INTO-EIGRP
R3(config-route-map)#match int lo 0
R3(config-route-map)#
R3(config-route-map)#router ei 65000
R3(config-router)#redist con route-map CON-INTO-EIGRP
R3(config-router)#net 10.3.3.3 0.0.0.0
R3(config-router)#

 

集約経路のみになる

R2#sh ip ro ei | b Gate
Gateway of last resort is not set

D     10.0.0.0/8 [90/30720] via 192.168.23.3, 00:02:13, FastEthernet1/0
R2#

 

R2 でauto-summary

R3 はLoopback0 を再配送

R3#sh ip int b | e una
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.23.3    YES manual up                    up
FastEthernet1/0            10.3.3.3        YES manual up                    up
Loopback0                  10.0.0.3        YES manual up                    up

R3#sh run | sec router eigrp
router eigrp 65000
 network 192.168.23.3 0.0.0.0
 redistribute connected route-map CON-INTO-EIGRP
 eigrp router-id 10.0.0.3
R3#
R3#sh run | sec route-map CON-INTO-EIGRP permit 10
route-map CON-INTO-EIGRP permit 10
 match interface Loopback0
R3#

 

R2 では外部経路で受信、R2 でauto-summary を設定

R2#sh ip ro ei | b Gate
Gateway of last resort is not set

      10.0.0.0/32 is subnetted, 1 subnets
D EX     10.0.0.3 [170/156160] via 192.168.23.3, 00:03:58, FastEthernet1/0
R2#sh run | sec router eigrp
router eigrp 65000
 network 192.168.12.2 0.0.0.0
 network 192.168.23.2 0.0.0.0
 eigrp router-id 10.0.0.2
R2#conf t
R2(config)#router eigrp 65000
R2(config-router)#auto-summary
R2(config-router)#

 

R1 では外部経路のまま

R1#sh ip ro ei | b Gate
Gateway of last resort is not set

      10.0.0.0/32 is subnetted, 1 subnets
D EX     10.0.0.3 [170/158720] via 192.168.12.2, 00:11:17, FastEthernet1/0
D     192.168.23.0/24 [90/30720] via 192.168.12.2, 00:53:45, FastEthernet1/0
R1#

 

R2 で10.台をEIGRP で有効にする

R2(config-router)#int lo 0
R2(config-if)#ip add 10.0.0.2 255.255.255.255
R2(config-if)#router eigrp 65000
R2(config-router)#net 10.0.0.2 0.0.0.0
R2(config-router)#

 

R1 では集約経路で受信

R1#sh ip ro ei | b Gate
Gateway of last resort is not set

D     10.0.0.0/8 [90/156160] via 192.168.12.2, 00:01:23, FastEthernet1/0
D     192.168.23.0/24 [90/30720] via 192.168.12.2, 00:57:41, FastEthernet1/0
R1#

 

自身で再配送、ネイバーから受信のどちらであっても、内部経路が無い場合はauto-summary では外部経路の集約はできない

コメント